{"metadata":{"image":[],"title":"","description":""},"api":{"url":"","auth":"required","params":[],"results":{"codes":[]},"settings":""},"next":{"description":"","pages":[]},"title":"Browser compatibility","type":"basic","slug":"browser-compatibility","excerpt":"","body":"Our general goal is for the LiftIgniter browser-client to be compatible with versions of major browsers that are up to five years old. We currently aim to be compatible with the following browsers:\n\n* Mozilla Firefox: 29 and higher though we may be compatible with earlier versions\n* Google Chrome: 32 and higher, though we may also be compatible with earlier versions\n* Internet Explorer: Only IE 11 (as of August 7, 2020, the LiftIgniter JS file runs in IE 10 as well but we don't aim to maintain IE 10 compatibility)\n* Microsoft Edge: All versions\n* Safari: 10 and higher, though we may also be compatible with older versions\n\nNote that the above compatibility is for core compatibility. Some diagnostic and debugging functionality may be limited to newer versions of browsers.\n\nWe also expect to be compatible with other standard browsers such as Opera, but do not explicitly run compatibility tests.\n\nAnother compatibility issue that might affect older browser/operating system combinations is that they may fail to recognize our HTTPS certificates that are issued by Let's Encrypt, after the DST Root CA X3 Expiration on September 30, 2021. This should not be an issue for the most up-to-date operating systems capable of running any of the above browsers listed above for compatibility.","updates":[],"order":5,"isReference":false,"hidden":false,"sync_unique":"","link_url":"","link_external":false,"_id":"57d8b007ed63190e0022d24a","project":"5668fab608f90021008e882f","user":"5668fa9755e4b32100935d41","__v":1,"category":{"sync":{"isSync":false,"url":""},"pages":["56a2c4990aefae0d00b7fee4","56a2c4a342dfda0d000463a3","56a2c4bf06150b0d002ad262","56a2c4dd2029df19002b595c","56ec9485406ab51700200633"],"title":"Web Debugging","slug":"debugging","order":9,"from_sync":false,"reference":false,"_id":"56a2c48a831e2a0d0069b1ad","version":"5668fab608f90021008e8832","__v":5,"createdAt":"2016-01-23T00:08:42.770Z","project":"5668fab608f90021008e882f"},"version":{"version":"1.18","version_clean":"1.18.0","codename":"","is_stable":true,"is_beta":false,"is_hidden":false,"is_deprecated":false,"categories":["5668fab708f90021008e8833","569740f124490c3700170a64","569742b58560a60d00e2c25d","569742bd0b09a41900b2446c","569742cd69393517000c82b3","569742f459a6692d003fad8f","569743020b09a41900b2446d","5697430b69393517000c82b5","56a17776470ae00d00c30642","56a2c48a831e2a0d0069b1ad","56b535757bccae0d00e9a1cd","56e1ff6aa49fdc0e005746b5","57e1c88115bf6522002a5e4e","57fa65275ba65a17008b988f","57fbeea34002550e004c032e","58474584889b6c2d00fb86e9","58475dcc64157f0f002f1907","587e7b5158666c2700965d4e","58a349fc30852819007ba083"],"_id":"5668fab608f90021008e8832","__v":19,"releaseDate":"2015-12-10T04:08:22.769Z","createdAt":"2015-12-10T04:08:22.769Z","project":"5668fab608f90021008e882f"},"createdAt":"2016-09-14T02:03:51.146Z","parentDoc":null,"githubsync":""}

Browser compatibility


Our general goal is for the LiftIgniter browser-client to be compatible with versions of major browsers that are up to five years old. We currently aim to be compatible with the following browsers: * Mozilla Firefox: 29 and higher though we may be compatible with earlier versions * Google Chrome: 32 and higher, though we may also be compatible with earlier versions * Internet Explorer: Only IE 11 (as of August 7, 2020, the LiftIgniter JS file runs in IE 10 as well but we don't aim to maintain IE 10 compatibility) * Microsoft Edge: All versions * Safari: 10 and higher, though we may also be compatible with older versions Note that the above compatibility is for core compatibility. Some diagnostic and debugging functionality may be limited to newer versions of browsers. We also expect to be compatible with other standard browsers such as Opera, but do not explicitly run compatibility tests. Another compatibility issue that might affect older browser/operating system combinations is that they may fail to recognize our HTTPS certificates that are issued by Let's Encrypt, after the DST Root CA X3 Expiration on September 30, 2021. This should not be an issue for the most up-to-date operating systems capable of running any of the above browsers listed above for compatibility.